Click or drag to resize

RenderContentSerializer Methods

The RenderContentSerializer type exposes the following members.

Methods
  NameDescription
Public methodCanLoadMultiple
If true the plug-in is capable of loading multiple contents.
Public methodLoadMultiple
Create any number of new render contents loaded from any number of files.
Public methodRead
Called to when importing a file, file should be parsed and converted to a valid RenderContent object.
Public methodRegisterSerializer
Register the RenderContentSerializer
Public methodReportContentAndFile
This is called from your implementation of LoadMultiple() to add a content and the file it was loaded from when the LoadMultipleFlags.Preload flag is NOT set. See LoadMultiple() for an explanation of this method's use.
Public methodReportDeferredContentAndFile
This is called from your implementation of LoadMultiple() to add a 'deferred' content and the file it will be loaded from when the LoadMultipleFlags.Preload flag is set. See LoadMultiple() for an explanation of this method's use. \param c is the deferred content. \param wszFullPath is the full path to the file that 'c' will be loaded from. \param flags is reserved for future use; you should pass zero. \param pReserved is reserved for future use; you should pass nullptr. */
Public methodWrite
Called to save a custom RenderContent object as an external file.
Top
See Also