Click or drag to resize

RenderContentType Class

Represents one of the render content types registered with Rhino.
Inheritance Hierarchy
SystemObject
  Rhino.RenderRenderContentType

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class RenderContentType : IDisposable

The RenderContentType type exposes the following members.

Constructors
  NameDescription
Public methodRenderContentType
Initializes a new instance of the RenderContentType class
Top
Properties
  NameDescription
Public propertyId
Returns the type identifier associated with this type.
Public propertyInternalName
Returns the internal name identifier associated with this type.
Public propertyPlugInId
Public propertyRenderEngineId
Top
Methods
  NameDescription
Public methodDispose
Releases all resources used by the RenderContentType
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the RenderContentType and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodStatic memberGetAllAvailableTypes
Gets an array of all available render content types registered with Rhino.
Public methodStatic memberNewContentFromTypeId(Guid)
Create a new content specified by the Guid. This function can be used to create temporary content, as it calls ::RhRdkContentFactories().NewContentFromType().
Public methodStatic memberNewContentFromTypeId(Guid, RhinoDoc)
Public methodNewRenderContent
Returns a new instance of the render content of this type. This content can be added to a persistant list.
Top
See Also