Click or drag to resize

SafeFrame Class

Safe frame
Inheritance Hierarchy

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class SafeFrame : DocumentOrFreeFloatingBase, 
	IDisposable

The SafeFrame type exposes the following members.

Constructors
  NameDescription
Public methodSafeFrame
Create a utility object not associated with any document
Public methodSafeFrame(RhinoDoc)
Create the SafeFrame object which is associated with the document
Public methodSafeFrame(SafeFrame)
Create a utility object not associated with any document from another object
Top
Properties
  NameDescription
Public propertyActionFrameLinked
Action Frame Linked, On = Use the same scale for X and Y. Off = use different scales for X and Y.
Public propertyActionFrameOn
Turn on the user specified action area, which shown with blue frames.
Public propertyActionFrameXScale
Action Frame X-scale. This value should be in the range 0..1 but it is not clamped. It is displayed in the UI in the range 0..100.
Public propertyActionFrameYScale
Action Frame Y-scale. This value should be in the range 0..1 but it is not clamped. It is displayed in the UI in the range 0..100.
Public propertyEnabled
Determines whether the safe-frame is enabled.
Public propertyFieldsOn
Show the 4 by 3 field grid in the safe-frame.
Public propertyLiveFrameOn
Turn on the live area, which shows the size of the rendered view as a yellow frame in the viewport.
Public propertyPerspectiveOnly
Show the safe-frame only in perspective views.
Public propertyTitleFrameLinked
Title Frame Linked, On = Use the same scale for X and Y. Off = use different scales for X and Y.
Public propertyTitleFrameOn
Show a user specified title area frame in orange.
Public propertyTitleFrameXScale
Title Frame X-scale. This value should be in the range 0..1 but it is not clamped. It is displayed in the UI in the range 0..100.
Public propertyTitleFrameYScale
Title Frame Y-scale. This value should be in the range 0..1 but it is not clamped. It is displayed in the UI in the range 0..100.
Top
Methods
  NameDescription
Public methodCopyFrom (Overrides FreeFloatingBaseCopyFrom(FreeFloatingBase).)
Public methodDispose
Releases all resources used by the SafeFrame
Protected methodFinalize
Top
Events
  NameDescription
Public eventStatic memberChanged
This event is raised when a SafeFrame property value is changed.
Top
See Also