Click or drag to resize

TexturedValueT Class

Generic class to help holding on to related values. This can be used to get data from textured content fields with the HandleTexturedValue function.
Inheritance Hierarchy
SystemObject
  Rhino.RenderTexturedValueT
    Rhino.RenderTexturedColor
    Rhino.RenderTexturedFloat

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.12
Syntax
public class TexturedValue<T>

Type Parameters

T
Color4f or float

The TexturedValueT type exposes the following members.

Constructors
  NameDescription
Public methodTexturedValueT
Initializes a new instance of the TexturedValueT class
Top
Methods
  NameDescription
Top
Fields
  NameDescription
Public fieldAmount
Public fieldName
Public fieldOn
Public fieldTexture
Public fieldValue
Top
See Also