RenderPrimitive Class |
[Missing <summary> documentation for "T:Rhino.Render.RenderPrimitive"]
Namespace: Rhino.Render
The RenderPrimitive type exposes the following members.
Name | Description | |
---|---|---|
BoundingBox |
The bounding box for this primitive.
| |
InstanceTransform |
Instance reference transform or Identity if not an instance reference.
| |
PrimitiveType |
Call this before extracting meshes if you support render primitives to
get the RenderPrimitiveType of this mesh then call the
associated TryGetSphere(Sphere), TryGetPlane(PlaneSurface), TryGetCone(Cone, Plane), or
TryGetBox(Box) method. Calling the Mesh property
will mesh the primitive and return a mesh always.
| |
RenderMaterial |
The RenderMaterial associated with this mesh or null if there is not one.
| |
RhinoObject |
The Rhino object associated with this render primitive.
|
Name | Description | |
---|---|---|
Dispose | Releases all resources used by the RenderPrimitive | |
Dispose(Boolean) | Releases the unmanaged resources used by the RenderPrimitive and optionally releases the managed resources | |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize | (Overrides ObjectFinalize.) | |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
Mesh |
Returns the mesh associated with the object, this will mesh primitives
and always return a mesh.
| |
ToString | Returns a string that represents the current object. (Inherited from Object.) | |
TryGetBox |
Call this method to get a Box primitive for this mesh. If this
meshes PrimitiveType is not a Box
then the box parameter is set to Empty.
| |
TryGetCone |
Call this method to get a Cone primitive for this mesh. If this
meshes PrimitiveType is not a Cone
then the cone parameter is set to Unset and the truncation
parameter is set to Unset.
| |
TryGetPlane |
Call this method to get a Plane primitive for this mesh. If this
meshes PrimitiveType is not a Plane
then the plane parameter is set to null.
| |
TryGetSphere |
Call this method to get a sphere primitive for this mesh. If this
meshes PrimitiveType is not a Sphere
then the sphere parameter is set to Unset.
|