Click or drag to resize

RenderPrimitive Methods

The RenderPrimitive type exposes the following members.

Methods
  NameDescription
Public methodDispose
Protected methodDispose(Boolean)
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodMesh
Returns the mesh associated with the object, this will mesh primitives and always return a mesh.
Public methodTryGetBox
Call this method to get a Box primitive for this mesh. If this meshes PrimitiveType is not a Box then the box parameter is set to Empty.
Public methodTryGetCone
Call this method to get a Cone primitive for this mesh. If this meshes PrimitiveType is not a Cone then the cone parameter is set to Unset and the truncation parameter is set to Unset.
Public methodTryGetPlane
Call this method to get a Plane primitive for this mesh. If this meshes PrimitiveType is not a Plane then the plane parameter is set to null.
Public methodTryGetSphere
Call this method to get a sphere primitive for this mesh. If this meshes PrimitiveType is not a Sphere then the sphere parameter is set to Unset.
Top
See Also