Click or drag to resize

LinearWorkflow Class

This is the interface to linear workflow settings.
Inheritance Hierarchy

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class LinearWorkflow : DocumentOrFreeFloatingBase, 
	IDisposable

The LinearWorkflow type exposes the following members.

Constructors
  NameDescription
Public methodLinearWorkflow
Create a utility object not associated with any document.
Public methodLinearWorkflow(LinearWorkflow)
Create a utility object not associated with any document from another object.
Top
Properties
  NameDescription
Public propertyHash
Linear workflow hash.
Public propertyPostProcessFrameBuffer
Linear workflow post-process frame buffer enabled state.
Public propertyPostProcessGamma
Linear workflow post-process gamma value.
Public propertyPostProcessGammaOn
Linear workflow post-process gamma enabled state.
Public propertyPostProcessGammaReciprocal
Reciprocal of linear workflow post-process gamma value.
Public propertyPreProcessColors
Linear workflow pre-process colors enabled state.
Public propertyPreProcessGamma
Linear workflow pre-process gamma value. This is currently the same as the post-process gamma value.
Public propertyPreProcessTextures
Linear workflow pre-process textures enabled state.
Top
Methods
  NameDescription
Public methodCopyFrom
Copy from another linear workflow object.
(Overrides FreeFloatingBaseCopyFrom(FreeFloatingBase).)
Public methodDispose
Releases all resources used by the LinearWorkflow
Public methodEquals
Compare two LinearWorkflow objects. They are considered equal if their hashes match.
(Overrides ObjectEquals(Object).)
Protected methodFinalize
Public methodGetHashCode
Get hash code for this object. It is the Hash property cast to int.
(Overrides ObjectGetHashCode.)
Top
See Also