RenderPanels Class |
Namespace: Rhino.Render
The RenderPanels type exposes the following members.
Name | Description | |
---|---|---|
FromRenderSessionId |
Get the instance of a render panel associated with a specific render
session, this is useful when it is necessary to update a control from a
RenderPipeline | |
RegisterPanel(PlugIn, RenderPanelType, Type, String, Boolean, Boolean) | Obsolete.
Register custom render user interface with Rhino. This should only be
done in RegisterRenderPanels(RenderPanels). Panels
registered after RegisterRenderPanels(RenderPanels) is called
will be ignored.
| |
RegisterPanel(PlugIn, RenderPanelType, Type, Guid, String, Boolean, Boolean) |
Register custom render user interface with Rhino. This should only be done in
RegisterRenderPanels(RenderPanels).
Panels registered after RegisterRenderPanels(RenderPanels) is called will be ignored.
| |
RegisterPanel(PlugIn, RenderPanelType, Type, Guid, String, Boolean, Boolean, RenderPanelsExtraSidePanePosition) |
Register custom render user interface with Rhino. This should only be done in
RegisterRenderPanels(RenderPanels).
Panels registered after RegisterRenderPanels(RenderPanels) is called will be ignored.
| |