Click or drag to resize

CustomRenderContentAttribute Class

Attributes for RenderContent
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Rhino.RenderCustomRenderContentAttribute

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class CustomRenderContentAttribute : Attribute

The CustomRenderContentAttribute type exposes the following members.

Constructors
  NameDescription
Public methodCustomRenderContentAttribute(String, Boolean, String, Boolean, Boolean, Boolean)
Initializes a new instance of the CustomRenderContentAttribute class
Public methodCustomRenderContentAttribute(String, Boolean, String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Initializes a new instance of the CustomRenderContentAttribute class
Top
Properties
  NameDescription
Public propertyCategory
Public propertyImageBased
Public propertyIsBuiltIn
Public propertyIsElevated
Public propertyIsHdrCapable
Public propertyIsLinear
Public propertyIsNormalMap
Public propertyIsPrivate
Public propertyRenderEngineId
Top
Methods
  NameDescription
Top
See Also