Click or drag to resize

CreatePreviewEventArgs Class

Used in RenderPlugIn virtual CreatePreview function
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Rhino.RenderCreatePreviewEventArgs

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class CreatePreviewEventArgs : EventArgs

The CreatePreviewEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyCancel
Get set by Rhino if the preview generation should be canceled for this
Public propertyContentKind
Description of content that preview is being generated for.
Public propertyContentTypeId
The class Id of content that preview is being generated for.
Public propertyEnvironment
The environment that the previewed object is rendered in.
Public propertyId
Unique Id for this scene.
Public propertyLights
Public propertyObjects
Public propertyPreviewContent Obsolete.
Obsolete, will return always null
Public propertyPreviewImage
Initially null. If this image is set, then this image will be used for the preview. If never set, the default internal simulation preview will be used.
Public propertyPreviewImageSize
Pixel size of the image that is being requested for the preview scene
Public propertyPreviewNotifier
Public propertyQuality
Quality of the preview image that is being requested for the preview scene
Public propertyReason
Reason the preview is getting generated
Public propertyViewport
Top
Methods
  NameDescription
Public methodSkipInitialisation
Call this if you don't want the argument to handle data initialisation. This is for use with the ChangeQueue
Top
See Also