RenderContentCollection Class |
Namespace: Rhino.Render
The RenderContentCollection type exposes the following members.
Name | Description | |
---|---|---|
![]() | RenderContentCollection |
Construct an empty collection of RenderContent objects
|
![]() | RenderContentCollection(IntPtr) |
Internal function to create collection from native pointer
|
Name | Description | |
---|---|---|
![]() | CppPointer |
Internal function to get native pointer
|
Name | Description | |
---|---|---|
![]() | Add |
Add an array of non-const contents to the collection.
|
![]() | Append |
Append a RenderContent to the collection
|
![]() | Clear |
Clear the collection.
|
![]() | ContentAt |
Content at index
|
![]() | ContentNeedsPreviewThumbnail |
To be documented
|
![]() | Count |
The number of items in the collection.
|
![]() | Dispose |
Dispose function for RenderContentCollection
|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize |
Finalizer for RenderContentCollection
(Overrides ObjectFinalize.) |
![]() | Find_Sel |
TODO
|
![]() | FirstTag |
Gets the first tag
|
![]() | GetEnumerator | |
![]() | GetFilterContentByUsage |
Gets usage filter type for collection
|
![]() | GetForcedVaries |
See SetForcedVaries
|
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetSearchPattern |
See SetSearchPattern
|
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | Iterator |
Gets an iterator for the collection
|
![]() | NextTag |
Call FirstTag first - this gets the next tag
|
![]() | Remove |
Remove an array of contents from the collection.
|
![]() | Set |
Set an array of const contents as the collection.
|
![]() | SetForcedVaries |
Set the collection to 'varies'.
Only valid if the collection is a 'selection' collection.
Useful for clients that only support single content selections.
|
![]() | SetSearchPattern |
Sets a search pattern for filtering contents. This is not actually used by the iterator,
but is stored for use by any UI that wants to filter contents based on a search string
by using the function RhRdkCheckSearchPattern()
|
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |