Click or drag to resize

RenderContentCollection Methods

The RenderContentCollection type exposes the following members.

Methods
  NameDescription
Public methodAdd
Add an array of non-const contents to the collection.
Public methodAppend
Append a RenderContent to the collection
Public methodClear
Clear the collection.
Public methodContentAt
Content at index
Public methodContentNeedsPreviewThumbnail
To be documented
Public methodCount
The number of items in the collection.
Public methodDispose
Dispose function for RenderContentCollection
Protected methodFinalize
Finalizer for RenderContentCollection
(Overrides ObjectFinalize.)
Public methodFind_Sel
TODO
Public methodFirstTag
Gets the first tag
Public methodGetEnumerator
Public methodGetFilterContentByUsage
Gets usage filter type for collection
Public methodGetForcedVaries
See SetForcedVaries
Public methodGetSearchPattern
See SetSearchPattern
Public methodIterator
Gets an iterator for the collection
Public methodNextTag
Call FirstTag first - this gets the next tag
Public methodRemove
Remove an array of contents from the collection.
Public methodSet
Set an array of const contents as the collection.
Public methodSetForcedVaries
Set the collection to 'varies'. Only valid if the collection is a 'selection' collection. Useful for clients that only support single content selections.
Public methodSetSearchPattern
Sets a search pattern for filtering contents. This is not actually used by the iterator, but is stored for use by any UI that wants to filter contents based on a search string by using the function RhRdkCheckSearchPattern()
Top
See Also