Click or drag to resize

ContentUndoBlocker Class

[Missing <summary> documentation for "T:Rhino.Render.ContentUndoBlocker"]

Inheritance Hierarchy
SystemObject
  Rhino.RenderContentUndoBlocker

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ContentUndoBlocker : IDisposable

The ContentUndoBlocker type exposes the following members.

Constructors
  NameDescription
Public methodContentUndoBlocker
Constructs a ContentUndoBlocker object inside a using block to block undo when modifying a RenderContent while a ContentUndoHelper is active. Alternatively - create the ContentUndoBlocker and explicitly call Dispose when you are done.
Top
Methods
  NameDescription
Public methodDispose
Releases all resources used by the ContentUndoBlocker
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the ContentUndoBlocker and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Top
See Also