Click or drag to resize

AsyncRenderContext Class

\ingroup rhino_render Inherit from AsyncRenderContext to be able to create asynchronous render engine implementations through RhinoCommon.
Inheritance Hierarchy
SystemObject
  Rhino.RenderAsyncRenderContext

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class AsyncRenderContext : IDisposable

The AsyncRenderContext type exposes the following members.

Constructors
  NameDescription
Protected methodAsyncRenderContext
Initializes a new instance of the AsyncRenderContext class
Top
Properties
  NameDescription
Protected propertyCancel
If set to true rendering should be stopped. Is set to true only by StopRendering().
Public propertyRenderThread
Holder for render thread, that gets set through StartRenderThread()
Public propertyRenderWindow
Handle to the RenderWindow for the instance of this class. This is a convenience property for implementors to use.
Top
Methods
  NameDescription
Protected methodDeleteThis
Public methodDispose
Releases all resources used by the AsyncRenderContext
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the AsyncRenderContext and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodJoinRenderThread
Join the render thread, then set to null;
Public methodStartRenderThread
Start a new render thread with given function.
Public methodStopRendering
Override StopRendering if you need to do additional tasks besides having Cancel set to true. Note: you should always base.StopRendering() in your overriding implementation.
Top
See Also