Click or drag to resize

PhysicallyBasedMaterialParametersNames Class

Note: This API is now obsolete.

Helper class with fields containing the names of fields available in our PBR implementation.
Inheritance Hierarchy
SystemObject
  Rhino.RenderPhysicallyBasedMaterialParametersNames

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[ObsoleteAttribute("Use Rhino.Render.ParameterNames.PhysicallyBased and Rhino.Render.ChildSlotNames.PhysicallyBaseds instead")]
public class ParametersNames

The PhysicallyBasedMaterialParametersNames type exposes the following members.

Constructors
  NameDescription
Public methodPhysicallyBasedMaterialParametersNames
Initializes a new instance of the PhysicallyBasedMaterialParametersNames class
Top
Properties
  NameDescription
Public propertyStatic memberAmbientOcclusion Obsolete.
Public propertyStatic memberAnisotropic Obsolete.
Public propertyStatic memberAnisotropicRotation Obsolete.
Public propertyStatic memberBaseColor Obsolete.
Public propertyStatic memberBRDF Obsolete.
Public propertyStatic memberBump Obsolete.
Public propertyStatic memberClearcoat Obsolete.
Public propertyStatic memberClearcoatBump Obsolete.
Public propertyStatic memberClearcoatRoughness Obsolete.
Public propertyStatic memberDisplacement Obsolete.
Public propertyStatic memberEmission Obsolete.
Public propertyStatic memberMetallic Obsolete.
Public propertyStatic memberNormal Obsolete.
Public propertyStatic memberOpacity Obsolete.
Public propertyStatic memberOpacityIor Obsolete.
Public propertyStatic memberOpacityRoughness Obsolete.
Public propertyStatic memberRoughness Obsolete.
Public propertyStatic memberSheen Obsolete.
Public propertyStatic memberSheenTint Obsolete.
Public propertyStatic memberSmudge Obsolete.
Public propertyStatic memberSpecular Obsolete.
Public propertyStatic memberSpecularTint Obsolete.
Public propertyStatic memberSubsurface Obsolete.
Public propertyStatic memberSubsurfaceScatteringColor Obsolete.
Public propertyStatic memberSubsurfaceScatteringRadius Obsolete.
Top
Methods
  NameDescription
Top
See Also