Click or drag to resize

TextureEvaluator Class

This is the interface to a lightweight object capable of evaluating texture color throughout uvw space. Derive from this class to create your own texture evaluator to return from a custom RenderTexture.
Inheritance Hierarchy
SystemObject
  Rhino.RenderTextureEvaluator

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class TextureEvaluator : IDisposable

The TextureEvaluator type exposes the following members.

Constructors
Methods
  NameDescription
Public methodDispose
For Dispose pattern
Protected methodDispose(Boolean)
For Dispose pattern
Protected methodFinalize
For Dispose pattern
(Overrides ObjectFinalize.)
Public methodGetColor(Point3d, Vector3d, Vector3d)
Get the color of the texture at a particular point in uvw space. May be called from within a rendering shade pipeline. note For ray differentials see Pharr Humphreys, "Physically Based Rendering", chapter 11.
Public methodGetColor(Point3d, Vector3d, Vector3d, Color4f)
Optimized version of GetColor for callers. Much faster in the case of a native (C++) evaluator.
Public methodInitialize
Call this function before calling GetColor for the first time. Ideally, this should be on the main thread, but you can also call it on a worker thread as long as you are sure that Initialize() or GetColor() cannot be called at the same time on another thread.
Public methodWriteToByteArray Obsolete.
Fast access to bitmap evaluator - supply size (which you will probably have received from CRhRdkTexture::PixelSize) to see if the data can be extracted direct to a width*height*4 array of unsigned chars.
Public methodWriteToByteArray2
Fast access to bitmap evaluator - supply size (which you will probably have received from CRhRdkTexture::PixelSize) to see if the data can be extracted direct to a width*height*4 array of unsigned chars.
Public methodWriteToFloatArray Obsolete.
Fast access to bitmap evaluator - supply size (which you will probably have received from CRhRdkTexture::PixelSize) to see if the data can be extracted direct to a width*height*4 array of unsigned chars.
Public methodWriteToFloatArray2
Fast access to bitmap evaluator - supply size (which you will probably have received from CRhRdkTexture::PixelSize) to see if the data can be extracted direct to a width*height*4 array of unsigned chars.
Top
See Also