TextureEvaluator Methods |
The TextureEvaluator type exposes the following members.
Name | Description | |
---|---|---|
Dispose |
For Dispose pattern
| |
Dispose(Boolean) |
For Dispose pattern
| |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize |
For Dispose pattern
(Overrides ObjectFinalize.) | |
GetColor(Point3d, Vector3d, Vector3d) |
Get the color of the texture at a particular point in uvw space.
May be called from within a rendering shade pipeline.
note For ray differentials see Pharr Humphreys, "Physically Based Rendering", chapter 11.
| |
GetColor(Point3d, Vector3d, Vector3d, Color4f) |
Optimized version of GetColor for callers. Much faster in the case of a native (C++) evaluator.
| |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
Initialize |
Call this function before calling GetColor for the first time. Ideally, this should
be on the main thread, but you can also call it on a worker thread as long as you
are sure that Initialize() or GetColor() cannot be called at the same time on another thread.
| |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
ToString | Returns a string that represents the current object. (Inherited from Object.) | |
WriteToByteArray | Obsolete.
Fast access to bitmap evaluator - supply size (which you will probably have received from CRhRdkTexture::PixelSize) to see
if the data can be extracted direct to a width*height*4 array of unsigned chars.
| |
WriteToByteArray2 |
Fast access to bitmap evaluator - supply size (which you will probably have received from CRhRdkTexture::PixelSize) to see
if the data can be extracted direct to a width*height*4 array of unsigned chars.
| |
WriteToFloatArray | Obsolete.
Fast access to bitmap evaluator - supply size (which you will probably have received from CRhRdkTexture::PixelSize) to see
if the data can be extracted direct to a width*height*4 array of unsigned chars.
| |
WriteToFloatArray2 |
Fast access to bitmap evaluator - supply size (which you will probably have received from CRhRdkTexture::PixelSize) to see
if the data can be extracted direct to a width*height*4 array of unsigned chars.
|