Click or drag to resize

RenderChannels Class

Render Channels. This corresponds to the user's settings in the Rendering panel.
Inheritance Hierarchy

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class RenderChannels : DocumentOrFreeFloatingBase, 
	IDisposable

The RenderChannels type exposes the following members.

Constructors
  NameDescription
Public methodRenderChannels
Create a utility object not associated with any document.
Top
Properties
  NameDescription
Public propertyCustomList
Public propertyMode
Top
Methods
  NameDescription
Public methodCopyFrom (Overrides FreeFloatingBaseCopyFrom(FreeFloatingBase).)
Public methodDispose
Releases all resources used by the RenderChannels
Protected methodFinalize (Overrides FreeFloatingBaseFinalize.)
Top
Events
  NameDescription
Public eventStatic memberChanged
This event is raised when a Render Channels property value is changed.
Top
See Also