Click or drag to resize

RenderContentStyles Enumeration

[Missing <summary> documentation for "T:Rhino.Render.RenderContentStyles"]

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.1
Syntax
[FlagsAttribute]
public enum RenderContentStyles
Members
  Member nameValueDescription
None0 No defined styles
TextureSummary1 Texture UI includes an auto texture summary section. See AddAutoParameters().
QuickPreview2 Editor displays an instant preview before preview cycle begins.
PreviewCache4 Content's preview imagery can be stored in the preview cache.
ProgressivePreview8 Content's preview imagery can be rendered progressively.
LocalTextureMapping16 Texture UI includes an auto local mapping section for textures. See AddAutoParameters()
GraphDisplay32 Texture UI includes a graph section.
NameTypeSection2048 Render content UI includes a 'Name' and 'Type' section.
SharedUI64 Obsolete. OBSOLETE: The UI is always shared between render contents of the same type id.
Adjustment128 Texture UI includes an adjustment section.
Fields256 Render content uses fields to facilitate data storage and undo support. See Fields()
ModalEditing512 Render content supports editing in a modal editor. OBSOLETE: All contents support modal editing.
DynamicFields1024 The render content's fields are dynamic. OBSOLETE: Dynamic fields can co-exist with static fields.
See Also