Click or drag to resize

Mesh Methods

The Mesh type exposes the following members.

Methods
  NameDescription
Public methodAppend(IEnumerableMesh)
Append a list of meshes. This function is much more efficient than making repeated calls to Mesh.Append(Mesh) when lots of meshes are being joined into a single large mesh.
Public methodCode exampleAppend(Mesh)
Appends a copy of another mesh to this one and updates indices of appended mesh parts.
Public methodCheck
Examines the mesh and logs a description of what it finds right or wrong. The various properties the function checks for are described in MeshCheckParameters.
Public methodClearSurfaceData
Removes surface parameters, curvature parameters and surface statistics from the mesh.
Public methodClearTextureData
Removes all texture coordinate information from this mesh.
Public methodClosestMeshPoint
Gets the point on the mesh that is closest to a given test point. Similar to the ClosestPoint function except this returns a MeshPoint class which includes extra information beyond just the location of the closest point.
Public methodClosestPoint(Point3d)
Gets the point on the mesh that is closest to a given test point.
Public methodClosestPoint(Point3d, Point3d, Double)
Gets the point on the mesh that is closest to a given test point.
Public methodClosestPoint(Point3d, Point3d, Vector3d, Double)
Gets the point on the mesh that is closest to a given test point.
Public methodCollapseFacesByArea
Collapses multiple mesh faces, with areas less than LessThanArea and greater than GreaterThanArea, based on the principles found in Stan Melax's mesh reduction PDF, see http://pomax.nihongoresources.com/downloads/PolygonReduction.pdf
Public methodCollapseFacesByByAspectRatio
Collapses a multiple mesh faces, determined by face aspect ratio, based on criteria found in Stan Melax's polygon reduction, see http://pomax.nihongoresources.com/downloads/PolygonReduction.pdf
Public methodCollapseFacesByEdgeLength
Collapses multiple mesh faces, with greater/less than edge length, based on the principles found in Stan Melax's mesh reduction PDF, see http://pomax.nihongoresources.com/downloads/PolygonReduction.pdf
Public methodColorAt(MeshPoint)
Evaluate a mesh color at a set of barycentric coordinates.
Public methodColorAt(Int32, Double, Double, Double, Double)
Evaluate a mesh normal at a set of barycentric coordinates. Barycentric coordinates must be assigned in accordance with the rules as defined by MeshPoint.T.
Public methodCode exampleCompact
Removes any unreferenced objects from arrays, re-indexes as needed and shrinks arrays to minimum required size.
Public methodComputeCurvatureApproximation
Compute an approximation of the discrete curvatures of the mesh vertices, according to which type of curvature information is requested. This method will not yield meaningful values on nonmanifold vertices, and nan on naked vertices. For now, this method operates solely on the mesh topology (the fully welded mesh), but distribtes the result across all the ordinary vertices. This method is a const and thread-safe method and will leave the m_K array untouched. An integer indicating which curvature is desired. gaussian_curvature = 1, mean_curvature = 2, minimum unsigned radius of curvature = 3, maximum unsigned radius of curvature = 4 Resulting curvature array on success, null on failure. On success, the length of the array is the number of vertices.
Public methodStatic memberComputeThickness(IEnumerableMesh, Double)
Compute thickness metrics for this mesh.
Public methodStatic memberComputeThickness(IEnumerableMesh, Double, CancellationToken)
Compute thickness metrics for this mesh.
Public methodStatic memberComputeThickness(IEnumerableMesh, Double, Double, CancellationToken)
Compute thickness metrics for this mesh.
Public methodCopyFrom
Copies mesh values into this mesh from another mesh.
Public methodStatic memberCreateBooleanDifference(IEnumerableMesh, IEnumerableMesh)
Computes the solid difference of two sets of Meshes.
Public methodStatic memberCreateBooleanDifference(IEnumerableMesh, IEnumerableMesh, MeshBooleanOptions, Result)
Computes the solid difference of two sets of Meshes.
Public methodStatic memberCreateBooleanIntersection(IEnumerableMesh, IEnumerableMesh)
Computes the solid intersection of two sets of meshes.
Public methodStatic memberCreateBooleanIntersection(IEnumerableMesh, IEnumerableMesh, MeshBooleanOptions, Result)
Computes the solid intersection of two sets of meshes.
Public methodStatic memberCreateBooleanSplit(IEnumerableMesh, IEnumerableMesh)
Splits a set of meshes with another set.
Public methodStatic memberCreateBooleanSplit(IEnumerableMesh, IEnumerableMesh, MeshBooleanOptions, Result)
Splits a set of meshes with another set.
Public methodStatic memberCreateBooleanUnion(IEnumerableMesh)
Computes the solid union of a set of meshes. WARNING: Use the overload that takes a tolerance or options.
Public methodStatic memberCreateBooleanUnion(IEnumerableMesh, Double)
Computes the solid union of a set of meshes.
Public methodStatic memberCreateBooleanUnion(IEnumerableMesh, MeshBooleanOptions, Result)
Computes the solid union of a set of meshes.
Public methodStatic memberCreateContourCurves(Mesh, Plane) Obsolete.
(Old call maintained for compatibility.)
Public methodStatic memberCreateContourCurves(Mesh, Plane, Double)
Constructs contour curves for a mesh, sectioned at a plane.
Public methodStatic memberCreateContourCurves(Mesh, Point3d, Point3d, Double) Obsolete.
(Old call maintained for compatibility.)
Public methodStatic memberCode exampleCreateContourCurves(Mesh, Point3d, Point3d, Double, Double)
Constructs contour curves for a mesh, sectioned along a linear axis.
Public methodStatic memberCreateConvexHull3D
Attempts to create a 3d convex hull mesh from input points.
Public methodStatic memberCreateExtrusion(Curve, Vector3d)
Constructs a mesh by extruding a curve along a vector.
Public methodStatic memberCreateExtrusion(Curve, Vector3d, MeshingParameters)
Constructs a mesh by extruding a curve along a vector.
Public methodStatic memberCreateFromBox(BoundingBox, Int32, Int32, Int32)
Constructs new mesh that matches a bounding box.
Public methodStatic memberCreateFromBox(Box, Int32, Int32, Int32)
Constructs new mesh that matches an aligned box.
Public methodStatic memberCreateFromBox(IEnumerablePoint3d, Int32, Int32, Int32)
Constructs new mesh from 8 corner points.
Public methodStatic memberCode exampleCreateFromBrep(Brep) Obsolete.
Constructs a mesh from a brep.
Public methodStatic memberCode exampleCreateFromBrep(Brep, MeshingParameters)
Constructs a mesh from a brep.
Public methodStatic memberCreateFromClosedPolyline
Attempts to create a Mesh that is a triangulation of a simple closed polyline that projects onto a plane.
Public methodStatic memberCreateFromCone(Cone, Int32, Int32)
Constructs a solid mesh cone.
Public methodStatic memberCreateFromCone(Cone, Int32, Int32, Boolean)
Constructs a mesh cone.
Public methodStatic memberCreateFromCone(Cone, Int32, Int32, Boolean, Boolean)
Constructs a mesh cone.
Public methodStatic memberCreateFromCurveExtrusion
Constructs a mesh from an extruded curve. This method is designed for projecting curves onto a mesh. In most cases, a better to use CreateExtrusion(Curve, Vector3d).
Public methodStatic memberCreateFromCurvePipe
Constructs a new mesh pipe from a curve.
Public methodStatic memberCreateFromCylinder(Cylinder, Int32, Int32)
Constructs a capped mesh cylinder.
Public methodStatic memberCreateFromCylinder(Cylinder, Int32, Int32, Boolean, Boolean)
Constructs a mesh cylinder.
Public methodStatic memberCreateFromCylinder(Cylinder, Int32, Int32, Boolean, Boolean, Boolean)
Constructs a mesh cylinder.
Public methodStatic memberCreateFromCylinder(Cylinder, Int32, Int32, Boolean, Boolean, Boolean, Boolean)
Constructs a mesh cylinder.
Public methodStatic memberCreateFromExtrusion
Constructs a mesh from a brep.
Public methodStatic memberCreateFromFilteredFaceList
Constructs a sub-mesh, that contains a filtered list of faces.
Public methodStatic memberCreateFromIterativeCleanup
Repairs meshes with vertices that are too near, using a tolerance value.
Public methodStatic memberCreateFromLines
Creates a mesh by analizing the edge structure. Input lines could be from the extraction of edges from an original mesh.
Public methodStatic memberCreateFromPatchSingleFace
Creates a single mesh face from the given input.
Public methodStatic memberCreateFromPlanarBoundary(Curve, MeshingParameters) Obsolete.
Do not use this overload. Use version that takes a tolerance parameter instead.
Public methodStatic memberCreateFromPlanarBoundary(Curve, MeshingParameters, Double)
Attempts to construct a mesh from a closed planar curve.RhinoMakePlanarMeshes
Public methodStatic memberCreateFromPlane
Constructs a planar mesh grid.
Public methodStatic memberCreateFromSphere
Constructs a mesh sphere.
Public methodStatic memberCreateFromSubD
Create a mesh from a SubD limit surface
Public methodStatic memberCreateFromSubDControlNet
Create a mesh from a SubD control net
Public methodStatic memberCreateFromSubDControlNetWithTextureCoordinates
Create a mesh from a SubD control net including texture coordinates
Public methodStatic memberCreateFromSurface(Surface)
Constructs a mesh from a surface
Public methodStatic memberCreateFromSurface(Surface, MeshingParameters)
Constructs a mesh from a surface
Public methodStatic memberCreateFromSurfaceControlNet
Calculate a mesh representation of a surface's control net.
Public methodStatic memberCreateFromTessellation
Attempts to create a mesh that is a triangulation of a list of points, projected on a plane, including its holes and fixed edges.
Public methodStatic memberCreateFromTorus
Constructs a mesh torus.
Public methodStatic memberCreateIcoSphere
Constructs a icospherical mesh. A mesh icosphere differs from a standard UV mesh sphere in that it's vertices are evenly distributed. A mesh icosphere starts from an icosahedron (a regular polyhedron with 20 equilateral triangles). It is then refined by splitting each triangle into 4 smaller triangles. This splitting can be done several times.
Public methodCreatePartitions
In ancient times (or modern smart phone times), some rendering engines were only able to process small batches of triangles and the CreatePartitions() function was provided to partition the mesh into subsets of vertices and faces that those rendering engines could handle.
Public methodStatic memberCreatePatch
Construct a mesh patch from a variety of input geometry.
Public methodStatic memberCreateQuadSphere
Constructs a quad mesh sphere. A quad mesh sphere differs from a standard UV mesh sphere in that it's vertices are evenly distributed. A quad mesh sphere starts from a cube (a regular polyhedron with 6 square sides). It is then refined by splitting each quad into 4 smaller quads. This splitting can be done several times.
Public methodCreateVertexColorsFromBitmap
Populate the vertex colors from a bitmap image.
Public methodDestroyPartition
Destroys mesh partition.
Public methodDestroyTopology
Removes topology data, forcing all topology information to be recomputed.
Public methodDestroyTree
Destroys the mesh vertex access tree.
Public methodDuplicate (Overrides GeometryBaseDuplicate.)
Public methodDuplicateMesh
Public methodEvaluateMeshGeometry
If the mesh has SurfaceParameters, the surface is evaluated at these parameters and the mesh geometry is updated.
Public methodExplodeAtUnweldedEdges
Explode the mesh into sub-meshes where a sub-mesh is a collection of faces that are contained within a closed loop of "unwelded" edges. Unwelded edges are edges where the faces that share the edge have unique mesh vertices (not mesh topology vertices) at both ends of the edge.
Public methodExtendSelectionByEdgeRidge
Suggests an extension of a selection set by using information related with topology and alignment.
Public methodExtendSelectionByFaceLoop
Suggests an extension of a face selection set by using information related with topology and alignment.
Public methodExtractNonManifoldEdges
Extracts, or removes, non-manifold mesh edges.
Public methodFileHole
Given a starting "naked" edge index, this function attempts to determine a "hole" by chaining additional naked edges together until if returns to the start index. Then it triangulates the closed polygon and either adds the faces to the mesh.
Public methodFillHoles
Attempts to determine "holes" in the mesh by chaining naked edges together. Then it triangulates the closed polygons adds the faces to the mesh.
Public methodFlip(Boolean, Boolean, Boolean)
Reverses the direction of the mesh.
Public methodFlip(Boolean, Boolean, Boolean, Boolean)
Reverses the direction of the mesh.
Public methodGetCachedTextureCoordinates(Guid)
Call this method to get cached texture coordinates for a texture mapping with the specified Id.
Public methodGetCachedTextureCoordinates(RhinoObject, Texture)
Returns cached texture coordinate set based on the texture. Make sure to set up cached texture coordinates for all textures in the material first by calling SetCachedTextureCoordinatesFromMaterial(RhinoObject rhinoObject, Rhino.DocObjects.Material material) If this function returns null then there are no texture coordinates available.
Public methodGetNakedEdgePointStatus
Returns an array of Boolean values equal in length to the number of vertices in this mesh. Each value corresponds to a mesh vertex and is set to true if the vertex is not completely surrounded by faces.
Public methodCode exampleGetNakedEdges
Returns all edges of a mesh that are considered "naked" in the sense that the edge only has one face.
Public methodGetNgonAndFacesCount
Public methodGetNgonAndFacesEnumerable
Retrieves a complete enumerable, i.e., one that provides an iterator over every face that is present, no matter if defined as a triangle, a quad, or a strictly over-four-sided ngon.
Public methodGetOutlines(Plane)
Constructs the outlines of a mesh projected against a plane.
Public methodGetOutlines(RhinoViewport)
Constructs the outlines of a mesh. The projection information in the viewport is used to determine how the outlines are projected.
Public methodGetOutlines(ViewportInfo, Plane)
Constructs the outlines of a mesh.
Public methodGetPartition
Retrieves a partition. See CreatePartitions(Int32, Int32) for details.
Public methodGetSelfIntersections
Gets the intersections of this mesh with itself.
Public methodGetUnsafeLock
Allows to obtain unsafe pointers to the underlying unmanaged data structures of the mesh.
Public methodHealNakedEdges
Attempts to "heal" naked edges in a mesh based on a given distance. First attempts to move vertices to neighboring vertices that are within that distance away. Then it finds edges that have a closest point to the vertex within the distance and splits the edge. When it finds one it splits the edge and makes two new edges using that point.
Public methodInvalidateCachedTextureCoordinates
Invalidates all cached texture coordinates. Call this function when you have made changes that will affect the texture coordinates on the mesh.
Public methodIsManifold
Returns true if every mesh "edge" has at most two faces.
Public methodIsManifold(Boolean, Boolean, Boolean)
Gets a value indicating whether or not the mesh is manifold. A manifold mesh does not have any edge that borders more than two faces.
Public methodIsPointInside
Determines if a point is inside a solid mesh.
Public methodMatchEdges
Moves face edges of an open mesh to meet adjacent face edges. The method will first try to match vertices, and then then it will try to split edges to make the edges match.
Public methodMergeAllCoplanarFaces(Double)
Merges adjacent coplanar faces into single faces.
Public methodMergeAllCoplanarFaces(Double, Double)
Merges adjacent coplanar faces into single faces.
Protected methodNonConstOperation
Clear local cache on non constant calls
(Overrides GeometryBaseNonConstOperation.)
Public methodNormalAt(MeshPoint)
Evaluate a mesh normal at a set of barycentric coordinates.
Public methodNormalAt(Int32, Double, Double, Double, Double)
Evaluate a mesh normal at a set of barycentric coordinates. Barycentric coordinates must be assigned in accordance with the rules as defined by MeshPoint.T.
Public methodOffset(Double)
Makes a new mesh with vertices offset a distance in the opposite direction of the existing vertex normals. Same as Mesh.Offset(distance, false)
Public methodOffset(Double, Boolean)
Makes a new mesh with vertices offset a distance in the opposite direction of the existing vertex normals. Optionally, based on the value of solidify, adds the input mesh and a ribbon of faces along any naked edges. If solidify is false it acts exactly as the Offset(distance) function.
Public methodOffset(Double, Boolean, Vector3d)
Makes a new mesh with vertices offset a distance along the direction parameter. Optionally, based on the value of solidify, adds the input mesh and a ribbon of faces along any naked edges. If solidify is false it acts exactly as the Offset(distance) function.
Public methodOffset(Double, Boolean, Vector3d, ListInt32)
Makes a new mesh with vertices offset a distance along the direction parameter. Optionally, based on the value of solidify, adds the input mesh and a ribbon of faces along any naked edges. If solidify is false it acts exactly as the Offset(distance) function. Returns list of wall faces, i.e. the faces that connect original and offset mesh when solidified.
Protected methodOnSwitchToNonConst
Performs some memory cleanup if necessary
(Overrides GeometryBaseOnSwitchToNonConst.)
Public methodPatchSingleFace
Creates a single mesh face from the given input. The new mesh will be apppended to this mesh.
Public methodPointAt(MeshPoint)
Evaluate a mesh at a set of barycentric coordinates.
Public methodPointAt(Int32, Double, Double, Double, Double)
Evaluates a mesh at a set of barycentric coordinates. Barycentric coordinates must be assigned in accordance with the rules as defined by MeshPoint.T.
Public methodPullCurve
Gets a polyline approximation of the input curve and then moves its control points to the closest point on the mesh. Then it "connects the points" over edges so that a polyline on the mesh is formed.
Public methodPullPointsToMesh
Pulls a collection of points to a mesh.
Public methodQuadRemesh(QuadRemeshParameters)
Quad remesh this mesh.
Public methodQuadRemesh(QuadRemeshParameters, IEnumerableCurve)
Quad remesh this mesh.
Public methodQuadRemeshAsync(QuadRemeshParameters, IProgressInt32, CancellationToken)
Quad remesh this mesh asynchronously.
Public methodQuadRemeshAsync(QuadRemeshParameters, IEnumerableCurve, IProgressInt32, CancellationToken)
Quad remesh this mesh asynchronously.
Public methodQuadRemeshAsync(IEnumerableInt32, QuadRemeshParameters, IEnumerableCurve, IProgressInt32, CancellationToken)
Quad remesh this mesh asynchronously.
Public methodStatic memberQuadRemeshBrep(Brep, QuadRemeshParameters)
Create QuadRemesh from a Brep Set Brep Face Mode by setting QuadRemeshParameters.PreserveMeshArrayEdgesMode
Public methodStatic memberQuadRemeshBrep(Brep, QuadRemeshParameters, IEnumerableCurve)
Create Quad Remesh from a Brep
Public methodStatic memberQuadRemeshBrepAsync(Brep, QuadRemeshParameters, IProgressInt32, CancellationToken)
Quad remesh this Brep asynchronously.
Public methodStatic memberQuadRemeshBrepAsync(Brep, QuadRemeshParameters, IEnumerableCurve, IProgressInt32, CancellationToken)
Quad remesh this Brep asynchronously.
Public methodRebuildNormals
Removes mesh normals and reconstructs the face and vertex normals based on the orientation of the faces.
Public methodReduce(ReduceMeshParameters)
Reduce polygon count
Public methodReduce(ReduceMeshParameters, Boolean)
Reduce polygon count
Public methodReduce(Int32, Boolean, Int32, Boolean)
Reduce polygon count
Public methodReduce(Int32, Boolean, Int32, Boolean, Boolean)
Reduce polygon count
Public methodReduce(Int32, Boolean, Int32, Boolean, CancellationToken, IProgressDouble, String)
Reduce polygon count
Public methodReduce(Int32, Boolean, Int32, Boolean, CancellationToken, IProgressDouble, String, Boolean)
Reduce polygon count
Public methodReleaseUnsafeLock
Updates the Mesh data with the information that was stored via the MeshUnsafeLock.
Public methodStatic memberRequireIterativeCleanup
Analyzes some meshes, and determines if a pass of CreateFromIterativeCleanup would change the array.

All available cleanup steps are used. Currently available cleanup steps are:

- mending of single precision coincidence even though double precision vertices differ.

- union of nearly identical vertices, irrespectively of their origin.

- removal of t-joints along edges.

Public methodSetCachedTextureCoordinates
Set cached texture coordinates using the specified mapping.
Public methodSetCachedTextureCoordinatesFromMaterial
Sets up cached texture coordinate set for each texture in the material. Textures in the Material define which mapping channels are used and the RhinoObject defines what texture mapping is used for each mapping channel. After this method is called all necessary texture coordinate sets are cached and correct texture coordinates for each texture can be fetched using GetCachedTextureCoordinates(RhinoObject rhinoObject, Rhino.DocObjects.Texture texture) If any texture coordinates are already cached they will not be re-computed.
Public methodSetSurfaceParametersFromTextureCoordinates
If the mesh does not have surface evaluation parameters, has texture coordinates, and the surface parameters can be set in a way so the existing texture coordinates can be computed from the surface parameters, then this function sets the surface parameters. This is useful when meshes that have texture coordinates and do not have surface parameters want to set the surface parameters in a way so that the texture mapping of type TextureMappingType.SurfaceParameters will restore the texture coordinates.
Public methodSetTextureCoordinates(TextureMapping, Transform, Boolean)
Set texture coordinates using given mapping and applying given transform. Set lazy to false to generate texture coordinates right away.
Public methodSetTextureCoordinates(TextureMapping, Transform, Boolean, Boolean)
Set texture coordinates using given mapping and applying given transform. Set lazy to false to generate texture coordinates right away.
Public methodShrinkWrap(ShrinkWrapParameters)
Returns a ShrinkWrapped mesh or null when a mesh was not created or error.
Public methodStatic memberShrinkWrap(IEnumerableMesh, ShrinkWrapParameters)
Creates a unified ShrinkWrap mesh from a collection of input meshes. Returns null on error or failure.
Public methodStatic memberShrinkWrap(PointCloud, ShrinkWrapParameters)
Creates a unified ShrinkWrap mesh from a point cloud returns null on error or failure
Public methodShrinkWrap(ShrinkWrapParameters, CancellationToken)
Returns a ShrinkWrapped mesh or null when a mesh was not created or error.
Public methodStatic memberShrinkWrap(IEnumerableGeometryBase, ShrinkWrapParameters, MeshingParameters)
Creates a unified ShrinkWrap mesh from a collection of GeometryBase objects. returns null or error on failure
Public methodSmooth(Double, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem)
Smooths a mesh by averaging the positions of mesh vertices in a specified region.
Public methodSmooth(Double, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem, Plane)
Smooths a mesh by averaging the positions of mesh vertices in a specified region.
Public methodSmooth(Double, Int32, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem, Plane)
Smooths a mesh by averaging the positions of mesh vertices in a specified region.
Public methodSmooth(IEnumerableInt32, Double, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem, Plane)
Smooths part of a mesh by averaging the positions of mesh vertices in a specified region.
Public methodSmooth(IEnumerableInt32, Double, Int32, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem, Plane)
Smooths part of a mesh by averaging the positions of mesh vertices in a specified region.
Public methodSolidOrientation
Determines orientation of a "solid" mesh.
Public methodSplit(IEnumerableMesh)
Split a mesh with a collection of meshes. Suggestion: upgrade to overload with tolerance. Does not split at coplanar intersections.
Public methodSplit(Mesh)
Split a mesh with another mesh. Suggestion: upgrade to overload with tolerance.
Public methodSplit(Plane)
Split a mesh by an infinite plane.
Public methodSplit(IEnumerableMesh, Double, Boolean, TextLog, CancellationToken, IProgressDouble)
Split a mesh with a collection of meshes.
Public methodSplit(IEnumerableMesh, Double, Boolean, Boolean, TextLog, CancellationToken, IProgressDouble)
Split a mesh with a collection of meshes.
Public methodSplitDisjointPieces
Splits up the mesh into its unconnected pieces.
Public methodSplitWithProjectedPolylines(IEnumerablePolylineCurve, Double)
Splits a mesh by adding edges in correspondence with input polylines, and divides the mesh at partitioned areas. Polyline segments that are measured not to be on the mesh will be ignored.
Public methodSplitWithProjectedPolylines(IEnumerablePolylineCurve, Double, TextLog, CancellationToken, IProgressDouble)
Splits a mesh by adding edges in correspondence with input polylines, and divides the mesh at partitioned areas. Polyline segments that are measured not to be on the mesh will be ignored.
Public methodSubdivide
Subdivides the faces of the mesh.
Public methodSubdivide(IEnumerableInt32)
Subdivides specific faces of the mesh.
Public methodUnifyNormals
Attempts to fix inconsistencies in the directions of mesh faces in a mesh. This function does not modify mesh vertex normals, it rearranges the mesh face winding and face normals to make them all consistent. Note, you may want to call Mesh.Normals.ComputeNormals() to recompute vertex normals after calling this functions.
Public methodUnifyNormals(Boolean)
Attempts to fix inconsistencies in the directions of mesh faces in a mesh. This function does not modify mesh vertex normals, it rearranges the mesh face winding and face normals to make them all consistent. Note, you may want to call Mesh.Normals.ComputeNormals() to recompute vertex normals after calling this functions.
Public methodUnweld
Makes sure that faces sharing an edge and having a difference of normal greater than or equal to angleToleranceRadians have unique vertices along that edge, adding vertices if necessary.
Public methodUnweldEdge
Adds creases to a smooth mesh by creating coincident vertices along selected edges.
Public methodUnweldVertices
Ensures that faces sharing a common topological vertex have unique indices into the MeshVertexList collection.
Public methodVolume
Compute volume of the mesh.
Public methodWeld
Makes sure that faces sharing an edge and having a difference of normal greater than or equal to angleToleranceRadians share vertices along that edge, vertex normals are averaged.
Public methodWithDisplacement
Constructs new mesh from the current one, with displacement applied to it.
Public methodWithEdgeSoftening
Constructs new mesh from the current one, with edge softening applied to it.
Public methodWithShutLining
Constructs new mesh from the current one, with shut lining applied to it.
Top
See Also