Click or drag to resize

MeshGetOutlines Method (ViewportInfo, Plane)

Constructs the outlines of a mesh.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public Polyline[] GetOutlines(
	ViewportInfo viewportInfo,
	Plane plane
)

Parameters

viewportInfo
Type: Rhino.DocObjectsViewportInfo
The viewport info that provides the outline direction.
plane
Type: Rhino.GeometryPlane
Usually the view's construction plane. If a parallel projection and view plane is parallel to this, then project the results to the plane.

Return Value

Type: Polyline
An array of polylines, or null on error.
See Also