Click or drag to resize

MeshCreateFromPlanarBoundary Method (Curve, MeshingParameters, Double)

Attempts to construct a mesh from a closed planar curve.RhinoMakePlanarMeshes

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static Mesh CreateFromPlanarBoundary(
	Curve boundary,
	MeshingParameters parameters,
	double tolerance
)

Parameters

boundary
Type: Rhino.GeometryCurve
must be a closed planar curve.
parameters
Type: Rhino.GeometryMeshingParameters
parameters used for creating the mesh.
tolerance
Type: SystemDouble
Tolerance to use during operation.

Return Value

Type: Mesh
New mesh on success or null on failure.
See Also