Click or drag to resize

MeshCreateBooleanUnion Method (IEnumerableMesh, Double)

Computes the solid union of a set of meshes.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public static Mesh[] CreateBooleanUnion(
	IEnumerable<Mesh> meshes,
	double tolerance
)

Parameters

meshes
Type: System.Collections.GenericIEnumerableMesh
Meshes to union.
tolerance
Type: SystemDouble
A valid tolerance value. See MeshIntersectionsTolerancesCoefficient

Return Value

Type: Mesh
An array of Mesh results or null on failure.
See Also