Click or drag to resize

MeshFlip Method (Boolean, Boolean, Boolean, Boolean)

Reverses the direction of the mesh.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax
public void Flip(
	bool vertexNormals,
	bool faceNormals,
	bool faceOrientation,
	bool ngonsBoundaryDirection
)

Parameters

vertexNormals
Type: SystemBoolean
If true, vertex normals will be reversed.
faceNormals
Type: SystemBoolean
If true, face normals will be reversed.
faceOrientation
Type: SystemBoolean
If true, face orientations will be reversed.
ngonsBoundaryDirection
Type: SystemBoolean
If true, ngon boundaries will be reversed
See Also