RhinoCommon API
RhinoCommon API
Namespaces
Rhino.Geometry
Mesh Class
Mesh Methods
Append Method
Check Method
ClearSurfaceData Method
ClearTextureData Method
ClosestMeshPoint Method
ClosestPoint Method
CollapseFacesByArea Method
CollapseFacesByByAspectRatio Method
CollapseFacesByEdgeLength Method
ColorAt Method
Compact Method
ComputeCurvatureApproximation Method
ComputeThickness Method
CopyFrom Method
CreateBooleanDifference Method
CreateBooleanIntersection Method
CreateBooleanSplit Method
CreateBooleanUnion Method
CreateContourCurves Method
CreateConvexHull3D Method
CreateExtrusion Method
CreateFromBox Method
CreateFromBrep Method
CreateFromClosedPolyline Method
CreateFromCone Method
CreateFromCurveExtrusion Method
CreateFromCurvePipe Method
CreateFromCylinder Method
CreateFromExtrusion Method
CreateFromFilteredFaceList Method
CreateFromIterativeCleanup Method
CreateFromLines Method
CreateFromPatchSingleFace Method
CreateFromPlanarBoundary Method
CreateFromPlane Method
CreateFromSphere Method
CreateFromSubD Method
CreateFromSubDControlNet Method
CreateFromSubDControlNetWithTextureCoordinates Method
CreateFromSurface Method
CreateFromSurfaceControlNet Method
CreateFromTessellation Method
CreateFromTorus Method
CreateIcoSphere Method
CreatePartitions Method
CreatePatch Method
CreateQuadSphere Method
CreateUnweldedMesh Method
CreateVertexColorsFromBitmap Method
DestroyPartition Method
DestroyTopology Method
DestroyTree Method
Duplicate Method
DuplicateMesh Method
EvaluateMeshGeometry Method
ExplodeAtUnweldedEdges Method
ExtendSelectionByEdgeRidge Method
ExtendSelectionByFaceLoop Method
ExtractNonManifoldEdges Method
FileHole Method
FillHoles Method
Flip Method
GetCachedTextureCoordinates Method
GetNakedEdgePointStatus Method
GetNakedEdges Method
GetNgonAndFacesCount Method
GetNgonAndFacesEnumerable Method
GetOutlines Method
GetPartition Method
GetSelfIntersections Method
GetUnsafeLock Method
HealNakedEdges Method
InvalidateCachedTextureCoordinates Method
IsManifold Method
IsPointInside Method
MatchEdges Method
MergeAllCoplanarFaces Method
NonConstOperation Method
NormalAt Method
Offset Method
OnSwitchToNonConst Method
PatchSingleFace Method
PointAt Method
PullCurve Method
PullPointsToMesh Method
QuadRemesh Method
QuadRemeshAsync Method
QuadRemeshBrep Method
QuadRemeshBrepAsync Method
RebuildNormals Method
Reduce Method
ReleaseUnsafeLock Method
RequireIterativeCleanup Method
SetCachedTextureCoordinates Method
SetCachedTextureCoordinatesFromMaterial Method
SetSurfaceParametersFromTextureCoordinates Method
SetTextureCoordinates Method
ShrinkWrap Method
Smooth Method
SolidOrientation Method
Split Method
SplitDisjointPieces Method
SplitWithProjectedPolylines Method
Subdivide Method
UnifyNormals Method
Unweld Method
UnweldEdge Method
UnweldVertices Method
Volume Method
Weld Method
WithDisplacement Method
WithEdgeSoftening Method
WithShutLining Method
Mesh
DestroyTree Method
Destroys the mesh vertex access tree.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since:
6.0
Syntax
C#
VB
Copy
public
void
DestroyTree
()
Public
Sub
DestroyTree
See Also
Reference
Mesh Class
Rhino.Geometry Namespace
Rhino 8.13.24317.13000 (2024-11-12)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com