Given a starting "naked" edge index, this function attempts to determine a "hole"
by chaining additional naked edges together until if returns to the start index.
Then it triangulates the closed polygon and either adds the faces to the mesh.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax public bool FileHole(
int topologyEdgeIndex
)
Public Function FileHole (
topologyEdgeIndex As Integer
) As Boolean
Parameters
- topologyEdgeIndex
- Type: SystemInt32
Starting naked edge index.
Return Value
Type:
Booleantrue if successful, false otherwise.
See Also