Click or drag to resize

MeshCreatePartitions Method

In ancient times (or modern smart phone times), some rendering engines were only able to process small batches of triangles and the CreatePartitions() function was provided to partition the mesh into subsets of vertices and faces that those rendering engines could handle.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.6
Syntax
public bool CreatePartitions(
	int maximumVertexCount,
	int maximumTriangleCount
)

Parameters

maximumVertexCount
Type: SystemInt32

[Missing <param name="maximumVertexCount"/> documentation for "M:Rhino.Geometry.Mesh.CreatePartitions(System.Int32,System.Int32)"]

maximumTriangleCount
Type: SystemInt32

[Missing <param name="maximumTriangleCount"/> documentation for "M:Rhino.Geometry.Mesh.CreatePartitions(System.Int32,System.Int32)"]

Return Value

Type: Boolean
true on success
See Also