Click or drag to resize

MeshCreateFromSphere Method

Constructs a mesh sphere.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static Mesh CreateFromSphere(
	Sphere sphere,
	int xCount,
	int yCount
)

Parameters

sphere
Type: Rhino.GeometrySphere
Base sphere for mesh.
xCount
Type: SystemInt32
Number of faces in the around direction.
yCount
Type: SystemInt32
Number of faces in the top-to-bottom direction.

Return Value

Type: Mesh

[Missing <returns> documentation for "M:Rhino.Geometry.Mesh.CreateFromSphere(Rhino.Geometry.Sphere,System.Int32,System.Int32)"]

Exceptions
ExceptionCondition
ArgumentExceptionThrown when sphere is invalid.
ArgumentOutOfRangeExceptionThrown when xCount is less than or equal to two.
ArgumentOutOfRangeExceptionThrown when yCount is less than or equal to two.
See Also