Click or drag to resize

MeshComputeThickness Method (IEnumerableMesh, Double, Double, CancellationToken)

Compute thickness metrics for this mesh.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static MeshThicknessMeasurement[] ComputeThickness(
	IEnumerable<Mesh> meshes,
	double maximumThickness,
	double sharpAngle,
	CancellationToken cancelToken
)

Parameters

meshes
Type: System.Collections.GenericIEnumerableMesh
Meshes to include in thickness analysis.
maximumThickness
Type: SystemDouble
Maximum thickness to consider. Use as small a thickness as possible to speed up the solver.
sharpAngle
Type: SystemDouble
Sharpness angle in radians.
cancelToken
Type: System.ThreadingCancellationToken
Computation cancellation token.

Return Value

Type: MeshThicknessMeasurement
Array of thickness measurements.
See Also