MeshShrinkWrap Method (IEnumerableGeometryBase, ShrinkWrapParameters, MeshingParameters) |
Creates a unified ShrinkWrap mesh from a collection of GeometryBase objects.
returns null or error on failure
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 8.3
Syntax public static Mesh ShrinkWrap(
IEnumerable<GeometryBase> geometryBases,
ShrinkWrapParameters parameters,
MeshingParameters meshingParameters
)
Public Shared Function ShrinkWrap (
geometryBases As IEnumerable(Of GeometryBase),
parameters As ShrinkWrapParameters,
meshingParameters As MeshingParameters
) As Mesh
Parameters
- geometryBases
- Type: System.Collections.GenericIEnumerableGeometryBase
[Missing <param name="geometryBases"/> documentation for "M:Rhino.Geometry.Mesh.ShrinkWrap(System.Collections.Generic.IEnumerable{Rhino.Geometry.GeometryBase},Rhino.Geometry.ShrinkWrapParameters,Rhino.Geometry.MeshingParameters)"]
- parameters
- Type: Rhino.GeometryShrinkWrapParameters
A ShrinkWrapParameters object that specifies the configuration settings for the ShrinkWrap process. - meshingParameters
- Type: Rhino.GeometryMeshingParameters
GeometryBase objects are converted to meshes first using the MeshingParameters provided. Those meshes are then used in the ShrinkWrap process.
Return Value
Type:
Mesh[Missing <returns> documentation for "M:Rhino.Geometry.Mesh.ShrinkWrap(System.Collections.Generic.IEnumerable{Rhino.Geometry.GeometryBase},Rhino.Geometry.ShrinkWrapParameters,Rhino.Geometry.MeshingParameters)"]
See Also