Click or drag to resize

MeshPointAt Method (Int32, Double, Double, Double, Double)

Evaluates a mesh at a set of barycentric coordinates. Barycentric coordinates must be assigned in accordance with the rules as defined by MeshPoint.T.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Point3d PointAt(
	int faceIndex,
	double t0,
	double t1,
	double t2,
	double t3
)

Parameters

faceIndex
Type: SystemInt32
Index of triangle or quad to evaluate.
t0
Type: SystemDouble
First barycentric coordinate.
t1
Type: SystemDouble
Second barycentric coordinate.
t2
Type: SystemDouble
Third barycentric coordinate.
t3
Type: SystemDouble
Fourth barycentric coordinate. If the face is a triangle, this coordinate will be ignored.

Return Value

Type: Point3d
A Point on the mesh or Point3d.Unset if the faceIndex is not valid or if the barycentric coordinates could not be evaluated.
See Also