Click or drag to resize

MeshCreateExtrusion Method (Curve, Vector3d, MeshingParameters)

Constructs a mesh by extruding a curve along a vector.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public static Mesh CreateExtrusion(
	Curve profile,
	Vector3d direction,
	MeshingParameters parameters
)

Parameters

profile
Type: Rhino.GeometryCurve
Profile curve to extrude.
direction
Type: Rhino.GeometryVector3d
Direction and length of extrusion.
parameters
Type: Rhino.GeometryMeshingParameters
Parameters used to create the mesh.

Return Value

Type: Mesh
A mesh on success or null on failure.
See Also