Click or drag to resize

MeshCreateExtrusion Method (Curve, Vector3d)

Constructs a mesh by extruding a curve along a vector.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public static Mesh CreateExtrusion(
	Curve profile,
	Vector3d direction
)

Parameters

profile
Type: Rhino.GeometryCurve
Profile curve to extrude.
direction
Type: Rhino.GeometryVector3d
Direction and length of extrusion.

Return Value

Type: Mesh
A mesh on success or null on failure.
See Also