Click or drag to resize

MeshVertexList Class

Provides access to the vertices and vertex-related functionality of a mesh.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.CollectionsMeshVertexList

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class MeshVertexList : IResizableList<Point3f>, 
	IList<Point3f>, ICollection<Point3f>, IEnumerable<Point3f>, 
	IEnumerable, IReadOnlyList<Point3f>, IReadOnlyCollection<Point3f>, 
	IList, ICollection

The MeshVertexList type exposes the following members.

Properties
  NameDescription
Public propertyCapacity
Gets or sets the total number of vertices the internal data structure can hold without resizing.
Public propertyCount
Gets or sets the number of mesh vertices.
Public propertyItem
Gets or sets the vertex at the given index. The index must be valid or an IndexOutOfRangeException will be thrown.
Public propertyUseDoublePrecisionVertices
Set to true if the vertices should be stored in double precision
Top
Methods
  NameDescription
Public methodAdd(Point3d)
Adds a new vertex to the end of the Vertex list.
Public methodAdd(Point3f)
Adds a new vertex to the end of the Vertex list.
Public methodCode exampleAdd(Double, Double, Double)
Adds a new vertex to the end of the Vertex list.
Public methodCode exampleAdd(Single, Single, Single)
Adds a new vertex to the end of the Vertex list.
Public methodAddVertices(IEnumerablePoint3d)
Adds a series of new vertices to the end of the vertex list.

This overload accepts double-precision points.

Public methodAddVertices(IEnumerablePoint3f)
Adds a series of new vertices to the end of the vertex list.

This overload accepts single-precision points.

Public methodAlign(Double, IEnumerableBoolean)
Moves mesh vertices that belong to naked edges to neighboring vertices, within the specified distance.

This forces unaligned mesh vertices to the same location and is helpful to clean meshes for 3D printing.

See the

_AlignMeshVertices
Rhino command for more information.

Public methodStatic memberAlign(IEnumerableMesh, Double, IEnumerableIEnumerableBoolean)
Moves mesh vertices that belong to naked edges to neighboring vertices, within the specified distance.

This forces unaligned mesh vertices to the same location and is helpful to clean meshes for 3D printing.

See the

_AlignMeshVertices
Rhino command for more information.

Public methodClear
Clears the Vertex list on the mesh.
Public methodCombineIdentical
Merges identical vertices.
Public methodCullUnused
Removes all vertices that are currently not used by the Face list.
Public methodDestroy
Releases all memory allocated to store faces. The list capacity will be 0 after this call.

Subsequent calls can add new items.

Public methodGetConnectedVertices
Gets indices of all vertices that form "edges" with a given vertex index.
Public methodGetEnumerator
Gets an enumerator that yields all mesh vertices (points) in this collection.
Public methodGetTopologicalIndenticalVertices
Gets a list of other vertices which are "topologically" identical to this vertex.
Public methodGetVertexFaces
Gets a list of all of the faces that share a given vertex.
Public methodHide
Hides the vertex at the given index.
Public methodHideAll
Hides all vertices in the mesh.
Public methodIsHidden
Gets a value indicating whether or not a vertex is hidden.
Public methodPoint3dAt
Get double precision location at a given index
Public methodRemove(IEnumerableInt32, Boolean)
Removes the vertices at the given indices and all faces that reference those vertices.
Public methodRemove(Int32, Boolean)
Removes the vertex at the given index and all faces that reference that index.
Public methodSetVertex(Int32, Point3d)
Sets or adds a vertex to the Vertex List.

If [index] is less than [Count], the existing vertex at [index] will be modified.

If [index] equals [Count], a new vertex is appended to the end of the vertex list.

If [index] is larger than [Count], the function will return false.

Public methodSetVertex(Int32, Point3f)
Sets or adds a vertex to the Vertex List.

If [index] is less than [Count], the existing vertex at [index] will be modified.

If [index] equals [Count], a new vertex is appended to the end of the vertex list.

If [index] is larger than [Count], the function will return false.

Public methodSetVertex(Int32, Double, Double, Double)
Sets or adds a vertex to the Vertex List.

If [index] is less than [Count], the existing vertex at [index] will be modified.

If [index] equals [Count], a new vertex is appended to the end of the vertex list.

If [index] is larger than [Count], the function will return false.

Public methodSetVertex(Int32, Single, Single, Single)
Sets or adds a vertex to the Vertex List.

If [index] is less than [Count], the existing vertex at [index] will be modified.

If [index] equals [Count], a new vertex is appended to the end of the vertex list.

If [index] is larger than [Count], the function will return false.

Public methodSetVertex(Int32, Double, Double, Double, Boolean)
Sets or adds a vertex to the Vertex List.

If [index] is less than [Count], the existing vertex at [index] will be modified.

If [index] equals [Count], a new vertex is appended to the end of the vertex list.

If [index] is larger than [Count], the function will return false.

Public methodShow
Shows the vertex at the given index.
Public methodShowAll
Shows all vertices in the mesh.
Public methodToFloatArray
Copies all vertices to a linear array of float in x,y,z order
Public methodToPoint3dArray
Copies all vertices to a new array of Point3d.
Public methodToPoint3fArray
Copies all vertices to a new array of Point3f.
Top
See Also