MeshVertexListAlign Method (Double, IEnumerableBoolean) |
Moves mesh vertices that belong to naked edges to neighboring vertices, within the specified distance.
This forces unaligned mesh vertices to the same location and is helpful to clean meshes for 3D printing.
See the
Rhino command for more information.
Namespace:
Rhino.Geometry.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax public int Align(
double distance,
IEnumerable<bool> whichVertices = null
)
Public Function Align (
distance As Double,
Optional whichVertices As IEnumerable(Of Boolean) = Nothing
) As Integer
Parameters
- distance
- Type: SystemDouble
Distance that should not be exceed when modifying the mesh. - whichVertices (Optional)
- Type: System.Collections.GenericIEnumerableBoolean
If not null, defines which vertices should be considered for adjustment.
Return Value
Type:
Int32If the operation succeeded, the number of moved vertices, or -1 on error.
See Also