MeshVertexListRemove Method (IEnumerableInt32, Boolean) |
Removes the vertices at the given indices and all faces that reference those vertices.
Namespace:
Rhino.Geometry.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Remove(
IEnumerable<int> indices,
bool shrinkFaces
)
Public Function Remove (
indices As IEnumerable(Of Integer),
shrinkFaces As Boolean
) As Boolean
Parameters
- indices
- Type: System.Collections.GenericIEnumerableInt32
Vertex indices to remove. - shrinkFaces
- Type: SystemBoolean
If true, quads that reference the deleted vertex will be converted to triangles.
Return Value
Type:
Booleantrue on success, false on failure.
See Also