MeshVertexListSetVertex Method (Int32, Point3d) |
Sets or adds a vertex to the Vertex List.
If [index] is less than [Count], the existing vertex at [index] will be modified.
If [index] equals [Count], a new vertex is appended to the end of the vertex list.
If [index] is larger than [Count], the function will return false.
Namespace:
Rhino.Geometry.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool SetVertex(
int index,
Point3d vertex
)
Public Function SetVertex (
index As Integer,
vertex As Point3d
) As Boolean
Parameters
- index
- Type: SystemInt32
Index of vertex to set. - vertex
- Type: Rhino.GeometryPoint3d
Vertex location.
Return Value
Type:
Booleantrue on success, false on failure.
See Also