MeshClosestPoint Method (Point3d) |
Gets the point on the mesh that is closest to a given test point.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public Point3d ClosestPoint(
Point3d testPoint
)
Public Function ClosestPoint (
testPoint As Point3d
) As Point3d
Parameters
- testPoint
- Type: Rhino.GeometryPoint3d
Point to search for.
Return Value
Type:
Point3dThe point on the mesh closest to testPoint, or Point3d.Unset on failure.
See Also