Click or drag to resize

FileObjWriteOptionsVertexWelding Enumeration

Determines how/if vertexes of the mesh in Rhino will be modified in the output

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public enum VertexWelding
Members
  Member nameValueDescription
Normal0 Mesh is exported in existing state
Welded1 Mesh topology vertex indexing is used for the v in the OBJ output file normals and texture coordinates, if they exist, come from the mesh
Unwelded2 Each face gets it's own vertex, and normal and texture coordinates if they exist, in the output
Remarks
The actual values of any vertex, normal or texture coordinate are not modified, this setting determines whether they are duplicated or merged.
See Also