SHA1OpenNURBS Class |
This class is provided only with the purpose of hashing. It is not meant to be used for any cryptographic purpose.
Namespace: Rhino.FileIO
The SHA1OpenNURBS type exposes the following members.
Name | Description | |
---|---|---|
SHA1OpenNURBS |
Constructs a new instance of the SHA1 algorithm.
|
Name | Description | |
---|---|---|
CanReuseTransform | Gets a value indicating whether the current transform can be reused. (Inherited from HashAlgorithm.) | |
CanTransformMultipleBlocks | When overridden in a derived class, gets a value indicating whether multiple blocks can be transformed. (Inherited from HashAlgorithm.) | |
Hash | Gets the value of the computed hash code. (Inherited from HashAlgorithm.) | |
HashSize | Gets the size, in bits, of the computed hash code. (Inherited from HashAlgorithm.) | |
InputBlockSize | When overridden in a derived class, gets the input block size. (Inherited from HashAlgorithm.) | |
OutputBlockSize | When overridden in a derived class, gets the output block size. (Inherited from HashAlgorithm.) |
Name | Description | |
---|---|---|
Clear | Releases all resources used by the HashAlgorithm class. (Inherited from HashAlgorithm.) | |
ComputeHash(Byte) | Computes the hash value for the specified byte array. (Inherited from HashAlgorithm.) | |
ComputeHash(Stream) | Computes the hash value for the specified Stream object. (Inherited from HashAlgorithm.) | |
ComputeHash(Byte, Int32, Int32) | Computes the hash value for the specified region of the specified byte array. (Inherited from HashAlgorithm.) | |
Dispose | Releases all resources used by the current instance of the HashAlgorithm class. (Inherited from HashAlgorithm.) | |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
FileSystemPathHash |
Computes the SHA1 hash of a file system path, converted to UTF8.
These file system paths have identical values of FileSystemPathHash(): /x/y/z/name.ext \x\y\z\name.ext /x//y//z/name.ext /x/y/a/b/c/../../../z/name.ext /X/Y/Z/NAME.EXT (When ignoreCase is true) | |
Finalize |
Instructs the runtime to reclaim unmanaged resources if the developer
forgot to call Dispose().
(Overrides ObjectFinalize.) | |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
Initialize |
Resets this instance of the algorithm, so that it can be used again.
It is not required to call this method after creation.
(Overrides HashAlgorithmInitialize.) | |
StringHash |
Computes the SHA1 hash of a string, converted to UTF8.
| |
ToString | Returns a string that represents the current object. (Inherited from Object.) | |
TransformBlock | Computes the hash value for the specified region of the input byte array and copies the specified region of the input byte array to the specified region of the output byte array. (Inherited from HashAlgorithm.) | |
TransformFinalBlock | Computes the hash value for the specified region of the specified byte array. (Inherited from HashAlgorithm.) |