Click or drag to resize

SHA1OpenNURBS Methods

The SHA1OpenNURBS type exposes the following members.

Methods
  NameDescription
Public methodStatic memberFileSystemPathHash
Computes the SHA1 hash of a file system path, converted to UTF8.

These file system paths have identical values of FileSystemPathHash():

/x/y/z/name.ext

\x\y\z\name.ext

/x//y//z/name.ext

/x/y/a/b/c/../../../z/name.ext

/X/Y/Z/NAME.EXT (When ignoreCase is true)

Protected methodFinalize
Instructs the runtime to reclaim unmanaged resources if the developer forgot to call Dispose().
(Overrides ObjectFinalize.)
Public methodInitialize
Resets this instance of the algorithm, so that it can be used again. It is not required to call this method after creation.
(Overrides HashAlgorithmInitialize.)
Public methodStatic memberStringHash
Computes the SHA1 hash of a string, converted to UTF8.
Top
See Also