Click or drag to resize

SHA1OpenNURBSStringHash Method

Computes the SHA1 hash of a string, converted to UTF8.

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static byte[] StringHash(
	string input
)

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Rhino.FileIO.SHA1OpenNURBS.StringHash(System.String)"]

Return Value

Type: Byte
A 20-byte long SHA1 hash.
Exceptions
ExceptionCondition
ArgumentNullExceptionWhen input is null.
See Also