Click or drag to resize

File3dm Class

Represents a 3dm file, which is stored using the OpenNURBS file standard.

The 3dm format is the main Rhinoceros storage format.

Visit http://www.opennurbs.com/ for more details.

Inheritance Hierarchy
SystemObject
  Rhino.FileIOFile3dm

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dm : IDisposable

The File3dm type exposes the following members.

Constructors
  NameDescription
Public methodFile3dm
Initializes a new instance of a 3dm file.
Top
Properties
  NameDescription
Public propertyAllDimStyles
Dimension Styles in this file.
Public propertyAllGroups
Groups in this file.
Public propertyAllHatchPatterns
Hatch patterns in this file.
Public propertyAllInstanceDefinitions
Instance definitions in this file
Public propertyAllLayers
Layers in this file.
Public propertyAllLinetypes
Linetypes in this file.
Public propertyAllMaterials
Materials in this file.
Public propertyAllNamedConstructionPlanes
Named construction planes in this file.
Public propertyAllNamedViews
Named views in this file.
Public propertyAllViews
Views that represent the RhinoViews which are displayed when Rhino loads this file.
Public propertyApplicationDetails
Gets or sets details for the application that wrote this file.
Public propertyApplicationName
Gets or sets the name of the application that wrote this file.
Public propertyApplicationUrl
Gets or sets a URL for the application that wrote this file.
Public propertyArchiveVersion
Gets the 3dm file archive version.
Public propertyCreated
Get the DateTime that this file was originally created. If the value is not set in the 3dm file, then DateTime.MinValue is returned
Public propertyCreatedBy
Gets a string that names the user who created the file.
Public propertyDimStyles Obsolete.
Dimension Styles in this file.
Public propertyEarthAnchorPoint
If set, this is the model's location on the earth. This information is used when the model is used with GIS information.
Public propertyEmbeddedFiles
The embedded files in this file.
Public propertyHatchPatterns Obsolete.
Hatch patterns in this file
Public propertyInstanceDefinitions Obsolete.
Instance definitions in this file.
Public propertyLastEdited
Get the DateTime that this file was last edited. If the value is not set in the 3dm file, then DateTime.MinValue is returned
Public propertyLastEditedBy
Gets a string that names the user who last edited the file.
Public propertyLayers Obsolete.
Layers in this file.
Public propertyLinetypes Obsolete.
Linetypes in this file.
Public propertyManifest
Retrieves the manifest with all object descriptions in this file.
Public propertyMaterials Obsolete.
Materials in this file.
Public propertyNamedConstructionPlanes
Named construction planes in this file.
Public propertyNamedViews
Named views in this file.
Public propertyNotes
Gets or sets the model notes.
Public propertyObjects
Gets access to the File3dmObjectTable class associated with this file, which contains all objects.
Public propertyPlugInData
Custom plug-in data in this file. This data is not attached to any geometry or attributes
Public propertyRenderEnvironments
The render environments in this file.
Public propertyRenderMaterials
The render materials in this file.
Public propertyRenderTextures
The render textures in this file.
Public propertyRevision
Gets or sets the revision number.
Public propertySettings
Settings include tolerance, and unit system, and defaults used for creating views and objects.
Public propertyStartSectionComments
Gets or sets the start section comments, which are the comments with which the 3dm file begins.
Public propertyStrings
Document user strings in this file
Public propertyViews
Views that represent the RhinoViews which are displayed when Rhino loads this file.
Top
Methods
  NameDescription
Public methodAudit Obsolete.
This function is only kept for forward assembly compatibility.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Public methodDump
Prepares a text dump of the entire model.
Public methodDumpSummary
Prepares a text dump of model properties and settings.
Public methodDumpToTextLog
Prepares a text dump of the entire model.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodStatic memberFromByteArray
Read a 3dm file from a byte array
Public methodGetPreviewImage
Preview image used for file explorer
Public methodIsValid(String) Obsolete.
The File3dm object is kept consistent during its creation. Therefore, this function now returns only true.
Public methodIsValid(TextLog) Obsolete.
The File3dm object is kept consistent during its creation. Therefore, this function now returns only true.
Public methodPolish Obsolete.
This function is only kept for forward assembly compatibility.
Public methodStatic memberRead(String)
Reads a 3dm file from a specified location.
Public methodStatic memberRead(String, File3dmTableTypeFilter, File3dmObjectTypeFilter)
Reads a 3dm file from a specified location.
Public methodStatic memberReadApplicationData
Reads only the application information from an existing 3dm file.
Public methodStatic memberReadArchiveVersion
Reads only the archive 3dm version from an existing 3dm file.
Public methodStatic memberReadDimensionStyles
Read the dimension styles table out of a 3dm file.
Public methodStatic memberReadEarthAnchorPoint
Reads only the earth anchor point from an existing 3dm file
Public methodStatic memberReadNotes
Reads only the notes from an existing 3dm file.
Public methodStatic memberReadPreviewImage
Attempts to read the preview image out of a 3dm file.
Public methodStatic memberReadRevisionHistory
Quickly check a file for it's revision information. This function does not read the entire file, just what it needs to get revision information out
Public methodStatic memberReadWithLog(String, String)
Read a 3dm file from a specified location and log any archive reading errors.
Public methodStatic memberReadWithLog(String, File3dmTableTypeFilter, File3dmObjectTypeFilter, String)
Reads a 3dm file from a specified location.
Public methodSetPreviewImage
Preview image used for file explorer
Public methodToByteArray
Write to an in-memory byte[]
Public methodToByteArray(File3dmWriteOptions)
Write to an in-memory byte[]
Public methodWrite(String, File3dmWriteOptions)
Writes contents of this model to an openNURBS archive. If the model is not valid, then Write will refuse to write it.
Public methodWrite(String, Int32)
Writes contents of this model to an openNURBS archive. If the model is not valid, then Write will refuse to write it.
Public methodStatic memberWriteMultipleObjects
Creates a simple 3dm file that contains a multiple geometric objects.
Public methodStatic memberWriteOneObject
Creates a simple 3dm file that contains a single geometric object.
Public methodWriteWithLog(String, File3dmWriteOptions, String)
Writes contents of this model to an openNURBS archive. If the model is not valid, then Write will refuse to write it.
Public methodWriteWithLog(String, Int32, String)
Writes contents of this model to an openNURBS archive. If the model is not valid, then Write will refuse to write it.
Top
See Also