Click or drag to resize

File3dm Methods

The File3dm type exposes the following members.

Methods
  NameDescription
Public methodAudit Obsolete.
This function is only kept for forward assembly compatibility.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Public methodDump
Prepares a text dump of the entire model.
Public methodDumpSummary
Prepares a text dump of model properties and settings.
Public methodDumpToTextLog
Prepares a text dump of the entire model.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodStatic memberFromByteArray
Read a 3dm file from a byte array
Public methodGetPreviewImage
Preview image used for file explorer
Public methodIsValid(String) Obsolete.
The File3dm object is kept consistent during its creation. Therefore, this function now returns only true.
Public methodIsValid(TextLog) Obsolete.
The File3dm object is kept consistent during its creation. Therefore, this function now returns only true.
Public methodPolish Obsolete.
This function is only kept for forward assembly compatibility.
Public methodStatic memberRead(String)
Reads a 3dm file from a specified location.
Public methodStatic memberRead(String, File3dmTableTypeFilter, File3dmObjectTypeFilter)
Reads a 3dm file from a specified location.
Public methodStatic memberReadApplicationData
Reads only the application information from an existing 3dm file.
Public methodStatic memberReadArchiveVersion
Reads only the archive 3dm version from an existing 3dm file.
Public methodStatic memberReadDimensionStyles
Read the dimension styles table out of a 3dm file.
Public methodStatic memberReadEarthAnchorPoint
Reads only the earth anchor point from an existing 3dm file
Public methodStatic memberReadNotes
Reads only the notes from an existing 3dm file.
Public methodStatic memberReadPreviewImage
Attempts to read the preview image out of a 3dm file.
Public methodStatic memberReadRevisionHistory
Quickly check a file for it's revision information. This function does not read the entire file, just what it needs to get revision information out
Public methodStatic memberReadWithLog(String, String)
Read a 3dm file from a specified location and log any archive reading errors.
Public methodStatic memberReadWithLog(String, File3dmTableTypeFilter, File3dmObjectTypeFilter, String)
Reads a 3dm file from a specified location.
Public methodSetPreviewImage
Preview image used for file explorer
Public methodToByteArray
Write to an in-memory byte[]
Public methodToByteArray(File3dmWriteOptions)
Write to an in-memory byte[]
Public methodWrite(String, File3dmWriteOptions)
Writes contents of this model to an openNURBS archive. If the model is not valid, then Write will refuse to write it.
Public methodWrite(String, Int32)
Writes contents of this model to an openNURBS archive. If the model is not valid, then Write will refuse to write it.
Public methodStatic memberWriteMultipleObjects
Creates a simple 3dm file that contains a multiple geometric objects.
Public methodStatic memberWriteOneObject
Creates a simple 3dm file that contains a single geometric object.
Public methodWriteWithLog(String, File3dmWriteOptions, String)
Writes contents of this model to an openNURBS archive. If the model is not valid, then Write will refuse to write it.
Public methodWriteWithLog(String, Int32, String)
Writes contents of this model to an openNURBS archive. If the model is not valid, then Write will refuse to write it.
Top
See Also