Click or drag to resize

File3dmReadWithLog Method (String, File3dmTableTypeFilter, File3dmObjectTypeFilter, String)

Reads a 3dm file from a specified location.

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.9
Syntax
public static File3dm ReadWithLog(
	string path,
	File3dmTableTypeFilter tableTypeFilterFilter,
	File3dmObjectTypeFilter objectTypeFilter,
	out string errorLog
)

Parameters

path
Type: SystemString
The file to read.
tableTypeFilterFilter
Type: Rhino.FileIOFile3dmTableTypeFilter
If tableTypeFilterFilter is None, then everything in the archive is read. Otherwise tableTypeFilterFilter identifies what tables should be read.
objectTypeFilter
Type: Rhino.FileIOFile3dmObjectTypeFilter
If objectTypeFilter is not None, then is a filter made by bitwise or-ing values to select which types of objects will be read from the model object table.
errorLog
Type: SystemString
Any archive reading errors are logged here.

Return Value

Type: File3dm
new File3dm on success, null on error.
Exceptions
ExceptionCondition
FileNotFoundExceptionIf path does not exist.
See Also