Click or drag to resize

FileReference Class

Manages a reference to an existing or non-existing file, using either or both absolute or relative paths. Once constructed, this class is immutable.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFileReference

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class FileReference : IDisposable

The FileReference type exposes the following members.

Constructors
  NameDescription
Public methodFileReference
Constructs a new instance of the FileReference class, given a fullPath, a relativePath a content hash and a status value.
Top
Properties
  NameDescription
Public propertyContentHash
Gets the content hash.
Public propertyFullPath
Gets the absolute path of this file reference.
Public propertyFullPathStatus
Gets the file reference status.
Public propertyIsSet
Returns an indication of the fact that the reference is actually set to a non-null value.
Public propertyRelativePath
Gets the relative path of this file reference.
Top
Methods
  NameDescription
Public methodStatic memberCreateFromFullAndRelativePaths
Returns a new file reference. This returns a new instance even if the path does not exist.
Public methodStatic memberCreateFromFullPath
Returns a new file reference. This returns a new instance even if the path does not exist.
Public methodDispose
Reclaims unmanaged resources used by this object.
Protected methodFinalize
Top
See Also