Click or drag to resize

FileReference Constructor

Constructs a new instance of the FileReference class, given a fullPath, a relativePath a content hash and a status value.

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public FileReference(
	string fullPath,
	string relativePath,
	ContentHash hash,
	FileReferenceStatus status
)

Parameters

fullPath
Type: SystemString

[Missing <param name="fullPath"/> documentation for "M:Rhino.FileIO.FileReference.#ctor(System.String,System.String,Rhino.FileIO.ContentHash,Rhino.FileIO.FileReferenceStatus)"]

relativePath
Type: SystemString

[Missing <param name="relativePath"/> documentation for "M:Rhino.FileIO.FileReference.#ctor(System.String,System.String,Rhino.FileIO.ContentHash,Rhino.FileIO.FileReferenceStatus)"]

hash
Type: Rhino.FileIOContentHash

[Missing <param name="hash"/> documentation for "M:Rhino.FileIO.FileReference.#ctor(System.String,System.String,Rhino.FileIO.ContentHash,Rhino.FileIO.FileReferenceStatus)"]

status
Type: Rhino.FileIOFileReferenceStatus

[Missing <param name="status"/> documentation for "M:Rhino.FileIO.FileReference.#ctor(System.String,System.String,Rhino.FileIO.ContentHash,Rhino.FileIO.FileReferenceStatus)"]

See Also