Click or drag to resize

ContentHash Class

Contains information that is useful to uniquely identify an object.
Remarks
This object is immutable.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOContentHash

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ContentHash : ICloneable, 
	IEquatable<ContentHash>

The ContentHash type exposes the following members.

Constructors
  NameDescription
Protected methodContentHash
Constructs a copy of a content hash.
Top
Properties
  NameDescription
Public propertyByteCount
Gets the length of the content, in bytes.
Public propertyHashTime
Gets the hash time, rounded to seconds.
Public propertySha1ContentHash
Gets the 20-bytes long SHA1 hash of the content.
Public propertySha1NameHash
Gets the 20-bytes long SHA1 hash of the name.
Top
Methods
  NameDescription
Public methodClone
Creates a copy of this content hash. Because content hash is immutable, this can be used as a deep copy.
Public methodStatic memberCreateFromFile
Creates a new ContentHash, representing the content of a file.
Public methodEquals(ContentHash)
Determines if another content hash has the same value.
Public methodEquals(Object)
Determines if another object is a content hash with same value.
(Overrides ObjectEquals(Object).)
Public methodGetHashCode
Gets an hash code for this content hash. Two equal content hashes have equal hash code. The other way around might not be true.
(Overrides ObjectGetHashCode.)
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Determines if two ContentHash instances are equal by value.
Public operatorStatic memberInequality
Determines if two ContentHash instances are different by value.
Top
See Also