Click or drag to resize

ContentHash Methods

The ContentHash type exposes the following members.

Methods
  NameDescription
Public methodClone
Creates a copy of this content hash. Because content hash is immutable, this can be used as a deep copy.
Public methodStatic memberCreateFromFile
Creates a new ContentHash, representing the content of a file.
Public methodEquals(ContentHash)
Determines if another content hash has the same value.
Public methodEquals(Object)
Determines if another object is a content hash with same value.
(Overrides ObjectEquals(Object).)
Public methodGetHashCode
Gets an hash code for this content hash. Two equal content hashes have equal hash code. The other way around might not be true.
(Overrides ObjectGetHashCode.)
Top
See Also