Click or drag to resize

File3dmEdgeSoftening Class

Represents the edge softening attached to file3dm object attributes.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFile3dmEdgeSoftening

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dmEdgeSoftening

The File3dmEdgeSoftening type exposes the following members.

Properties
  NameDescription
Public propertyChamfer
Specifies whether to chamfer the edges.
Public propertyEdgeAngleThreshold
Threshold angle (in degrees) which controls whether an edge is softened or not. The angle refers to the angles between the adjacent faces of an edge.
Public propertyFaceted
Specifies whether the edges are faceted.
Public propertyForceSoftening
Specifies whether to soften edges despite too large a radius.
Public propertyOn
Specifies whether edge softening is enabled or not.
Public propertySoftening
The softening radius.
Top
Methods
  NameDescription
Top
See Also